Modem ZTE mf110 en Ubuntu

11 02 2010

Hola todos.  Tenía tiempo de no hacer un “how to” por problemas de tiempo pero creo que este si se lo merece.

Pues bien, si tienes un modem ZTE mf110 puedes hacerlo funcionar en Ubuntu 9.10 siguiendo estos pasos(en Ubuntu 10.04 funciona de una):

1. Descargamos e instalamos via synaptic el paquete usb_modeswitch o si no posees internet aún, descárgatelo desde aquí, y lo instalas con doble click.

2. Una vez instalado, abrimos una terminal y editamos el archivo de configuración del paquete (copia y pega):

$ sudo gedit /etc/usb_modeswitch.conf

y pegamos al final del archivo lo siguiente:

###################################################
# ZTE MF110
#
# Contributor: Fernando Anthony Ristagno
###################################################

DefaultVendor=0x19d2
DefaultProduct=0x2000

TargetVendor=0x19d2
TargetProduct=0x0031

MessageEndpoint=0x1
MessageContent="55534243b8fe6681000000000000061b000000020000000000000000000000"

3. Ahora creamos el siguiente archivo:

sudo gedit /etc/udev/rules.d/55-ztemf110.rules

y pegamos lo siguiente:

SUBSYSTEM=="usb", SYSFS{idProduct}=="2000", SYSFS{idVendor}=="19d2", RUN+="/usr/sbin/usb_modeswitch"

Una vez hecho esto podemos reiniciar el equipo y listo, a crear nuestra cuenta de conexión móvil.

Para crear nuestra cuenta hacemos los siguiente:

1. Conectamos el dispositivo, esperamos un minuto a que reciba la señal, y pinchamos el ícono de red.  Nos debe aparecer un cuadro como el siguiente y seleccionamos la conexión móvil de banda ancha

2. Nos aparece el asistente de configuración para la conexión y sequimos los pasos.

3. Elegimos el país de nuestro proveedor, en mi caso es Colombia.4. Seleccionamos nuestro operador.

5. Elegimos nuestro plan.  Si no es el predeterminado podemos contactar al servicio al cliente de nuestro proveedor y verificar la información.

6. Confirmamos la configuración de la conexión.

7. Ahora podemos establecer la conexión:

Espero que les sirva de ayuda.  Recuerda que la mejor forma de agradecer es dejando un comentario.

Tomado de | wanda25.com

Dedicado a | zte corporation (por la falta de soporte a Gnu/Linux)


Acciones

Information

37 responses

12 02 2010
Edgar

Hola! intenté usar varios howto pero este es el que finalmente me funcionó.. pero cuando intento conectar me pide contraseña? será del proveedor? te pasó lo mismo?
gracias por el tuto.

Saludos.

12 02 2010
argordmel

Cuando te conectas a una red inalámbrica con clave te pide una contraseña de desbloqueo? si es así dale esa clave a ver que pasa, cualquier cosa comentas….

12 02 2010
Edgar

No, no es una contraseña de desbloqueo.. es algo de la conexión.. dice:
Se necesita una contraseña para conectar con <>
ZTE Incorporated ZTE WCDMA Technologies MSM

Muy raro.. no sé a qué password se refiere.

Saludos.

12 02 2010
argordmel

Por lo que veo…a mi me pasó exactamente lo mismo probando el modem con otra simcard diferente a la del operador del dispositivo…

12 02 2010
Edgar

Encontraste alguna solución?

12 02 2010
argordmel

la única solución es desbloquear esa restricción que coloca el proveedor del modem.

Aqui explican como hacerlo pero no te garantizo que funcione para el zte mf110 (lee los comentarios) , esto es bajo tu responsabilidad: http://www.taringa.net/posts/celulares/4108626/Liberar-Modem-ZTE-mf626-%C2%A1Gratis!.html

13 02 2010
Edgar

Mmm… gracias por el comentario pero no creo que ese sea mi problema, el modem 3g y el chip son de personal y están tal cual me lo enviaron…
Seguiré buscando.

13 02 2010
argordmel

ok, cualquier cosa comentas!

Agur y saludos desde algún lugar de Colombia!!!

6 05 2010
Zuhs|

Hola, yo también tengo el mismo problema que Edgar.
El que encuentre primero la solución, por favor postearla.

6 05 2010
argordmel

En Lucid Lynx funciona a la perfección sin necesidad de cofigurarlo!

14 02 2010
Edgar

Sigo sin lograr nada.. arrrrrrrrggggg

#conf /etc/wvdial.conf
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGMM
Init4 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init5 = AT+CGDCONT=1,”IP”,”gprs.personal.com.ar”
Password = adgj
Phone = *99#
Modem type = USB Modem
Stupid Mode = 1
Baud = 460800
New PPPD = 1
Dial Command = ATD
Modem = /dev/ttyUSB2
ISDN = 0
Username = gprs

el log cuando ejecuto wvdial me dice:
Feb 14 02:17:08 ed-laptop pppd[3325]: pppd 2.4.5 started by root, uid 0
Feb 14 02:17:08 ed-laptop pppd[3325]: Using interface ppp0
Feb 14 02:17:08 ed-laptop pppd[3325]: Connect: ppp0 /dev/ttyUSB2
Feb 14 02:17:08 ed-laptop pppd[3325]: CHAP authentication succeeded
Feb 14 02:17:08 ed-laptop pppd[3325]: CHAP authentication succeeded
Feb 14 02:17:10 ed-laptop pppd[3325]: Modem hangup
Feb 14 02:17:10 ed-laptop pppd[3325]: Connection terminated.
Feb 14 02:17:10 ed-laptop pppd[3325]: Exit.

Toda configuración que pruebo en el log veo que intenta conectar y luego el modem cuelga… no logro encontrar por qué…

2 06 2010
Eduardo

estou com o mesmo problema que o Edgar e o Zuhs|, alguien encontró una solución?

3 06 2010
Eduardo

La compañía que uso 3G aquí en Brasil es llamada “Claro”, en la lista de correo de LoCoTeam el brasileño Wanderley me dio la siguiente receta:

El problema aquí es: No elija “3G”, pero “mi plan no es
cotizan en bolsa “o algo así. y luego rellenar el campo” APN “de la siguiente manera:
bandalarga.claro.com.br
y seguir con el resto de la configuración.
Tiene un campo, “red” que, al menos por aquí, me fui en blanco y no
hecho una diferencia, se conecta normalmente.
OBS.: de acuerdo a los asistentes del curso, el número que debe marcar el módem
* 99 *** 1 #
aquí no funcionó. Por lo tanto, la sugerencia del asistente
Ubuntu y dejar como
* 99 #
no da ninguna otra se conecta sin problemas.
Al final de la configuración, desconecte el módem, espere unos 30 segundos,
el módem usb stick y puede conectarlo.

lástima por los pobres en español: (
y buena suerte!

2 04 2010
Modems 3G USB para banda ancha móvil en Linux | Geekotic

[…] info al respecto en BlogDrake y Zona de Sistemas. Entradas que (tal vez) tienen algo que ver:El chiste de los adaptadores para tecnologías […]

23 04 2010
Julio

Despues de probar varias alternativas con usb_modeswitch, con este how to pude finalmente hacer funcionar mi modem zte mf 110 en Ubuntu, y en diferentes maquinas
(PC, notebook y netbook) muchas, pero muchas gracias!!

25 04 2010
David

Hola. Comparto la opinión de Julio. Después de varias guias sin éxito éste sí funcionó, al fin! Gracias. Este tutorial me sirvió en Ubuntu 9.10 64 bits. Operador Movistar. Colombia.
Fecha: 25/Abril/2010

1 06 2010
gonzalo

no puedo hacer q ande el modem claro ZTE mf110 en ubuntu 10.04 . alguien me podria ayudar ?

2 06 2010
argordmel

En ubuntu 10.04 funciona sin realizar este how-to. Verifica los datos de tu operador….

3 06 2010
Zuhs

A mi me funciona el modem ZTE o HUAWEI en Ubuntu 10.04 sin ningún problema y sin tener que hacer configuraciones a archivos.
Sólo hay que configurar la red Banda Ancha móvil con los datos correspondientes y ya está.

Con respecto a lo de Edgar, yo también tuve el mismo problema, pero de un momento para otro desapareció, lo más probable es que fuera el operador que estaba poniendo problemas.

12 06 2010
Gonzalo Trujillo

Se agradece el aporte, funciona impecable. Y efectivamente en ubuntu 10.04 es Plug and Play.

Saludos

19 06 2010
LEANDRO

HOLA QUIERO CONECTAR MI MODEM ZTE MF 110 MOVISTAR Y NO PUEDO HACERLO EN EL UBUNTU 10.04 PERO SI EN WINDOWS.UBUNTU NO RECONOCE LA BANDA ANCHA.QUE TENGO QUE HACER?GRACIAS,HASTA LUEGO

21 06 2010
argordmel

Disculpa que te responda tan tarde, he estado desconectado un buen tiempo.

El modem en Ubuntu 10.04 es Plug and Play, así que revisa los datos de tu conexión.

Nota: el modem una vez conectado demora un poco en ser habilitado. Verifica el ícono de red en tu panel de información.

Cualquier cosa comentas…

19 06 2010
LEANDRO

DONDE PUEDO DESCARGAR USB-MODESWITCH VIA SYNAPTIC, PORQUE EN ESTA PAGINA NO PUEDO.

21 06 2010
argordmel

Si tienes ubuntu 10.04 Lucid Lynx no es necesario instalarlo.

6 07 2010
david

yo necesito conectar mi moden zte mf110 pero no se como me pueden ayudar por favor

1 08 2010
ricardoasa

Funciona.

Gracias!

8 08 2010
David

Hola, gracias por el post.
Tuve el mismo problema que un usuario anterior, cuando insertaba el ZTE MF110 me pedía contraseña, esto lo solucioné ingresando la clave: internet
La solución la encontré en http://www.psicofxp.com/forums/gnu-linux.50/921867-internet-3-5g-ubuntu-9-04-a.html#qrform

Uso Lucid, modem ZTE MF110, Movistar. Nunca tuve un problema en Lucid con el reconocimiento del modem internet, siempre me salia la red de movistar en Network Manager, solo que al seleccionar esa red me pedía contraseña, ingrese la contraseña editando la red (en network manager) y grabé. No tuve que hacer nada más. Saludos para todos.

8 12 2010
riguel

bueno tengo com movistar un plan que me dicen es de 2 gb al consumir segun ellos estos gigas me mandan un mensaje, para informarme que la velosidad se desminura pero al corte de la mensualidad se restablesera. esto para mi es una burla por que cuando contrate no me dijeron esto. ok ya tengo que aguantar un año con esto segun el contrato. por !!!! FAVOR HAY ALGUNA FORMA DE BUERLAS ESTO POR FA HAY ALGUIEN QUE TENGA ALGUNA INFORMACION……..

9 12 2010
argordmel

Lamentablemente a mí me ha tocado aguantarme 11 mese… ahora paso la carta de cancelación de servicio….

17 01 2011
Yeison

si mal no estoy, solamente funciona con el usb-modeswitch 0.9.7 y está en tar.gz, aquí les dejo la direccion de donde lo pueden descargar.

https://launchpad.net/ubuntu/+source/usb-modeswitch/0.9.7-1

25 03 2011
Carlos Marziali

Aviso: Tienen que cambiar los datos de PRODUCT con los que aparecen en lsusb.

De lo contrario no va a encontrar el dispositivo.

25 05 2011
Galo

Saludos linuxeros, tengo el modem ZTE MF 190, cuando conecto a red de HSPA 3G funciona normalmente, pero cuando conecto a GPRS/EDGE 2G se cuelga toda la maquina, con un pantallazo negro y me parpadea la luz de “caps lock”, y no da ni con apagado de emergencia!!, todo esta instalado, no que que es lo que pasa, si alguien tuviera una solucion para configurarlo bien???, espero respuestas, mi correo es galo.rpqc@gmail.com, muchas gracias, hasta luego.

14 06 2011
Cesar Augusto Trujillo

la verdad a mi nunca me ha dado problemas la conexion de usb en ubuntu, lo que si molesta es la cobertura del servicio.

2 12 2011
miguel angel

buenas tengo un problema con el bam 3g de digitel (venezuela) tengo ubuntu 10.0 y al conectar el bam lo configuro con todos los pasos, provedor, pais y el tipo que plan que es el predeterminado, mi problema es que al conectarse se desconecta tras un lapso de treinta segundos aproximadamente, alquien podria ayudarme

3 02 2012
kty

quiero desbloquear mi modem es de la comania claro qiero ponerle chip movistar y m pide codigo de imei cual es!!!!!!!!!!!!

26 03 2012
ley

hola NECESITO ayuda soy de venezuela tengo un ZTE mf110 de DIGITEL y no logro conectarlo a ubuntu 10.04… ya e hecho lo comentado y nada

24 09 2012
Parmita Nagy

I love your blog.. very nice colors & theme.
Did you make this website yourself or did you hire someone to
do it for you? Plz respond as I’m looking to create my own blog and would like to know where u got this from. appreciate it

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




A %d blogueros les gusta esto: